Build Your Own Clone Message Board

It is currently Thu Aug 17, 2017 5:26 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sat Mar 18, 2017 11:07 am 
Offline

Joined: Sat Mar 18, 2017 11:01 am
Posts: 3
I just finished the Tweed Royal kit. The build went well with no complications. I tested voltages and they all seem good. The P.P. mode of the amp works fine and sounds good. The Single Ended mode of the amp does nothing. No sound at all. Anyone have this issue? Thanks in advance for any help.


Top
 Profile  
 
PostPosted: Sat Mar 18, 2017 12:03 pm 
Offline
Moderator
User avatar

Joined: Wed Apr 26, 2006 5:14 pm
Posts: 7921
Location: Truckee, CA
Sounds like you need to triple check your rotary switch wiring. Review the instructions again and make sure you didn't wire anything on the SE circuit/small transformer incorrectly.

If you post clear photos of your rotary switch wiring we'll help you look for faults.

_________________
MasterDelayer/Reverbrador/Ampaholic/TopJacker


Top
 Profile  
 
PostPosted: Sat Mar 18, 2017 12:40 pm 
Offline

Joined: Sat Mar 18, 2017 11:01 am
Posts: 3
Hey, I have triple checked the rotary switch but I still could have missed something. Here are some pictures and thanks for the help. And I know the resistor is missing on the Cut pot and the light is not in.


Attachments:
20170318_192321.jpg
20170318_192321.jpg [ 331.21 KiB | Viewed 209 times ]
20170318_192144.jpg
20170318_192144.jpg [ 335.07 KiB | Viewed 209 times ]
Top
 Profile  
 
PostPosted: Sun Mar 19, 2017 5:52 am 
Offline

Joined: Sat Mar 18, 2017 11:01 am
Posts: 3
Well. I checked the switch again. Then decided to trouble shoot a little more. I swapped the 2 6V6S with another set and low and behold both modes work! The PP mode is very nice but the SE mode is a bit noisy. I am hearing some crackling. So I will keep digging.

Sent from my GT-I9506 using Tapatalk


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group